NetComm NB604N modem/router and the Shellshock bug

The Shellshock bash bug has been getting a lot of press, and rightly so, as there are a large number of servers and devices potentially vulnerable, including devices such as ADSL modem/routers.  I went looking to see if my NetComm NB604N modem/router was vulnerable, but couldn’t find any official word on the matter.

With a bit of investigation myself by telnetting to the modem I established that the modem is running BusyBox with the ‘msh’ shell, not ‘bash’.

So my understanding is that the NB604N is NOT vulnerable to the Shellshock bug.

NB604N-Shell

Leave a Reply

Your email address will not be published. Required fields are marked *